Since Debian Lenny was finally released not so long ago, I started upgrading some machines. Unfortunately, aptitude dist-upgrade complained about a few packages:

    The following packages have unmet dependencies:
    libsasl2: Depends: libsasl2-2 (= 2.1.22.dfsg1-8) but 2.1.22.dfsg1-23 is to be installed.
    Resolving dependencies...
    The following actions will resolve these dependencies:

    Install the following packages:
    openssh-blacklist-extra [0.4.1 (stable)]
    xauth [1:1.0.3-2 (stable)]

    Keep the following packages at their current version:
    bash [3.1dfsg-8 (now)]
    dbus [1.0.2-1+etch2 (now)]
    libsasl2-2 [2.1.22.dfsg1-8 (now)]
    libsasl2-modules [2.1.22.dfsg1-8 (now)]
    libuuid1 [1.39+1.40-WIP-2006.11.14+dfsg-2etch1 (now)]
    ntpdate [1:4.2.2.p4+dfsg-2 (now)]
    nvi [1.79-25 (now)]
    po-debconf [1.0.8 (now)]

    Leave the following dependencies unresolved:
    dpkg-dev recommends build-essential
    Score is -444

To fix this, I simply removed the package libsasl2. Afterwards, aptitude dist-upgrade no longer complains about any dependencies :-)

Update: the better way would be to first run "aptitude install aptitude", and then "aptitude dist-upgrade".