Blog

iPhone 3.1.2, Cydia and Icy

So, recently I updated my iPhone to 3.1.2. Unfortunately, the custom firmware image I used contained both Cydia and Icy. I don't own an Apple computer myself, so I am unable to build my own custom IPSW, so I asked somebody else. And no, I will not use redsn0w because it sucks. It never worked for me on my iPhone 2G, it always came in recovery mode while it should go in DFU mode. Or was it the other way around?

Now it seems, if you install both Icy and Cydia, that Icy messes up the Apt/DPKG database. Joy ... Cydia errors when trying to install anything:

Cydia: Error Couldn’t configure pre-depend dpkg for ncurses, probably a dependency cycle.

Tags: 

Topics: 

Drupal migration

As you might have already noticed, I recently migrated my blog from WordPress to Drupal.

I used the WP2Drupal to import all WordPress posts from my old blog into my new Drupal-based website. It worked pretty good, except for some images that were missing, and some stuff showed up that didn't belong in posts, like Captcha text. After enabling some modules, I manually added the missing images, and while at it, I also removed text that got lost ;-)

Tags: 

Topics: 

iTunes ratings to Rhythmbox

Recently I got so tired of Windows, that I decided to throw it out completely. I stopped playing video games on my PC for about a year or so, since I bought a new Xbox 360 (the old one had a RROD, and was banned from Xbox Live anyway).

So I installed Gentoo on my desktop, and with that, I  no longer use iTunes.  Well, iTunes sucked anyway, but I used it to synchronize my iPhone, and since all my music was in that library, I might as well just use iTunes for playing music...

Tags: 

Topics: 

Dist-upgrade Etch to Lenny

Since Debian Lenny was finally released not so long ago, I started upgrading some machines. Unfortunately, aptitude dist-upgrade complained about a few packages:

The following packages have unmet dependencies:
libsasl2: Depends: libsasl2-2 (= 2.1.22.dfsg1-8) but 2.1.22.dfsg1-23 is to be installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Install the following packages:
openssh-blacklist-extra [0.4.1 (stable)]
xauth [1:1.0.3-2 (stable)]

Keep the following packages at their current version:
bash [3.1dfsg-8 (now)]
dbus [1.0.2-1+etch2 (now)]
libsasl2-2 [2.1.22.dfsg1-8 (now)]
libsasl2-modules [2.1.22.dfsg1-8 (now)]
libuuid1 [1.39+1.40-WIP-2006.11.14+dfsg-2etch1 (now)]
ntpdate [1:4.2.2.p4+dfsg-2 (now)]

Tags: 

Topics: 

Gentoo gnome-light

I have always had a problem with Evolution being installed when emerging gnome on my Gentoo system. Even with "-evo -eds" use flags, it still wanted Evolution.

Evolution is a BIG piece of CRAP, and I don't want it anywhere on my system. So I edited the gnome-base/gnome ebuild, and made all evolution stuff dependant on the "evo" or "eds" use flags, which worked fine.

However, I wanted to know why I can't have Gnome without Evolution, and I started asking around... Turns out that you can emerge gnome-light .... Sweet ;-)

Tags: 

Topics: 

Pages

Subscribe to RSS - blogs